DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

DokuWiki System Requirements

To run your own copy of DokuWiki you will need the following:

A Webserver supporting PHP

DokuWiki will run on any web server, that supports PHP. Most users use Apache or nginx, but many others including IIS, litespeed, lighttpd, OpenBSD httpd and Abyss are known to work.

PHP version 7.2 up to latest PHP version 7.4.x or PHP 8.0 - 8.1

PHP needs to be at least version 7.2 since the « Igor » release, support for previous PHP versions has been dropped on this release. PHP versions up to and including 7.3 are now EOL, therefore using the latest version of the 7.4.x branch or 8.x is highly recommended. Dokuwiki is compatible with PHP 8.0 and 8.1.

For resizing images either the PHP GD extension or Image Magick should be installed.

A recent browser

Any modern browser should work, but check our browser recommendations.

See also

requirements.txt · Last modified: 2022-08-02 09:01 by Klap-in

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki