DokuWiki

It's better when it's simple

ユーザ用ツール

サイト用ツール


サイドバー

この翻訳は元のページよりも更新日が古く、内容が古い可能性があります。 変更点を参照して下さい。
このページの翻訳?:

DokuWiki について知る

開発

法人利用

我々のコミュニティ


FacebookTwitterや他のソーシャル・ネットワークからフォローしてください。

ja:requirements

DokuWiki のシステム要件

DokuWiki を動作させるためには、以下のものが必要となります。

1. PHP に対応した Web サーバー

DokuWiki は PHP に対応していれば、どんな Web サーバー上でも動作します。 多くのユーザーは Apache を利用しますが、IIS や lighttpd、nginx、Abyss を含む他のサーバーでも動作することが判っています。

2. PHP 5.3.3 以上

PHP は少なくとも 5.3.3 バージョンにする必要があります。 しかし、より新しいバージョンを強くお勧めします。

画像のリサイズのためには、PHP GD 関数Image Magick が必要です。

PHP のセーフモードでも稼働しますが、サーバーの設定によっては設定項目: safemodehack を有効にする必要があるかもしれません。

PHP PCRE 関数は、UTF-8 対応としてコンパイルする必要があります。 pcretest -C を実行し、“UTF-8 support”(または “UTF-8 and UTF-16 support”)と “Unicode properties support” を探してこのことを確認できます。 1)

3. 最近の Web ブラウザ

最近の Web ブラウザであれば動作するはずですが、ブラウザの推奨事項を確認して下さい。

関連項目

1)
UTF-8 対応でない場合、検索結果のスニペットが存在せず、検索結果のリンクを辿ってもページは空です。
ja/requirements.txt · 最終更新: 2015-07-31 17:03 by sawachan