DokuWiki

It's better when it's simple

Uživatelské nástroje

Nástroje pro tento web


Postranní lišta

Tento překlad je starší než originální stránka a nejspíše i zastaralý. Zobrazit změny.
Překlady této stránky?:

Learn about DokuWiki

Advanced Use

Corporate Use

Our Community


Follow us on Facebook, Twitter and other social networks.

Our Privacy Policy

cs:requirements

Požadavky na provoz DokuWiki

Pro spuštění vlastní kopie DokuWiki potřebujete následující:

1. Webserver s podporou PHP

DokuWiki běží na jakémkoliv webovém serveru, který podporuje PHP. Většina uživatelů používá Apache, ale mnozí také IIS, lighttpd, nginx nebo Abyss. Pokud chcete použít wiki jako desktop verzi, můžete využít také QuickPHP (webový server a PHP v jednom souboru).

2. PHP verze 5.6 nebo novější

PHP alespoň ve verzi 5.6.

Pro změnu velikosti obrázků je potřeba, aby bylo buďto rozšíření PHP GD nebo Image Magick nainstalováno.

DokuWiki by mělo fungovat v PHP Safe Mode, ale v závislosti na nastavení vašeho hostingu možná budete potřebovat použít safemodehack nastavení .

Knihovna pcre v PHP musí být skompilována s podporou UTF-8. Můžete to vyzkoušet spuštěním pcretest -C a zkontrolováním výskytu „UTF-8 support“ (nebo „UTF-8 and UTF-16 support“) a „Unicode properties support“. 1)

PHP 7.0 instalace (na Ubuntu 16.04 nebo debian 9) potřebuje mít instalovaný balík php-xml. (Opraví error: Uncaught Error: Call to undefined function utf8_decode() )

3. Aktuální webový prohlížeč

Jakýkoliv aktuální webový prohlížeč by měl fungovat, ale můžete zkontrolovat doporučení k prohlížečům.

Další

1)
Pokud UTF-8 support chybí, bude chybět vyhledávací snippet na stránce výsledků vyhledávání a pokud budete následovat odkazy z výsledků, stránky budou prázdné.
cs/requirements.txt · Poslední úprava: 2017-07-26 09:14 autor: 195.113.23.55