DokuWiki

It's better when it's simple

Outils pour utilisateurs

Outils du site


Panneau latéral

Traductions de cette page?:

Découvrir DokuWiki

Options avancées

Pour les entreprises

Notre Communautée


Suivez-nous sur Facebook, Twitter et les autres résaux sociaux.

Notre politique de confidentialité

fr:requirements

Configuration requise

Pour faire tourner votre propre DokuWiki, vous devrez disposer de :

1. Un serveur Web avec support PHP

DokuWiki tourne sur tous les serveurs avec support du PHP. La majorité des utilisateurs utilisent Apache mais beaucoup d'autres fonctionnent également comme IIS, litespeed, lighttpd, Nginx ou Abyss.

2. PHP 5.6 et suivants

La version de PHP doit être supérieure ou égale à la 5.6 mais les versions plus récentes sont chaudement recommandées.

Pour redimensionner les images, l'extension GD doit être installée. DokuWiki peut aussi utiliser Image Magick.

DokuWiki devrait fonctionner en Safe Mode mais selon la configuration de votre hébergement, vous aurez peut-être besoin d'activer le paramètre de configuration safemodehack.

La bibliothèque pcre de PHP doit être compilée avec le support pour UTF-8. Vous pouvez vérifier que c'est le cas grâce à la commande pcretest -C. Vous devez trouver dans la trace d'exécution “UTF-8 support” (ou “UTF-8 and UTF-16 support”) et “Unicode properties support”. 1)

PHP 7.0 l'installation (sur Ubuntu 16.04 ou debian 9) nécessite d'installer le paquet php-xml. (Fixes error: Uncaught Error: Call to undefined function utf8_decode() )

3. Un navigateur récent

N'importe quel navigateur récent devrait fonctionner. Vous pouvez quand-même vérifier la prise en charge des navigateurs.

Voir aussi

1)
S'il n'y a pas de support UTF-8, il n'y aura pas d'extrait dans les résultats de recherche, et lorsque vous suivrez les liens des résultats de recherche, vous tomberez sur une page vide.
fr/requirements.txt · Dernière modification: 2018-05-10 11:14 par Digitalin