DokuWiki

It's better when it's simple

Benutzer-Werkzeuge

Webseiten-Werkzeuge


Seitenleiste

Übersetzungen dieser Seite?:

Erfahre mehr über DokuWiki

DokuWiki erweitern

Geschäftliche Nutzung

Unsere Community


Folge uns auf Facebook, Twitter und anderen Sozialen Netzwerken.

de:requirements

DokuWiki Systemvoraussetzungen

Um eine Kopie von DokuWiki zu verwenden benötigt man folgende drei Dinge:

1. Webserver mit PHP-Unterstützung

Apache wird bevorzugt, aber auch von vielen Anderen wird eine problemlose DokuWiki-Integration berichtet.

2. PHP 5.3.3 oder höher.

  • PHPs GD Erweiterung für libGD 2 (eine Grafikbibliothek) wird empfohlen, aber ist nicht zwingend notwendig
  • DokuWiki sollte in PHPs Safe Mode laufen, abhängig von der Konfiguration wird möglicherweise der safemodehack benötigt
  • DokuWiki ist dafür ausgelegt, ohne die register_globals-Konfiguration von PHP zu laufen.
  • Wenn das E-Mail-Registrierungsverfahren für neue Benutzer gewünscht ist, muss PHP eine funktionierende Mail-Konfiguration haben. (see: mail)

3. Einen aktuellen Web-Browser

Jeder Browser der letzten paar Jahre sollte funktionieren. Mit Firefox oder Chromium sollten gute Erfahrungen zu machen sein.

Sonstiges

Zusätzliche Plugins können darüber hinaus weitere Voraussetzungen besitzen.

Siehe auch

de/requirements.txt · Zuletzt geändert: 2020-08-03 13:23 von Michaelsy