DokuWiki

It's better when it's simple

User Tools

Site Tools


tips:image-in-the-upper-right-corner

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
tips:image-in-the-upper-right-corner [2009-09-02 11:33] 164.140.159.143tips:image-in-the-upper-right-corner [2014-04-18 11:16] (current) 82.150.248.37
Line 1: Line 1:
 +----
 +FIXME: This page seems deprecated as uploading a file named "logo.png" into wiki namespace, or at wiki's root replaces the template's logo.
 +----
  
-==== Having an image instead of title text in the upper-right corner ==== +===== Having an image instead of title text in the upper-right corner ===== 
-You can see this one in action here: http://deshalbfrei.immermusik.de/+ 
 +You can see this one in action here: **FIXME LINK CRASHED!** <del>http://deshalbfrei.immermusik.de/</del>
  
  
Line 22: Line 26:
 >> For me it had to be src="_media/logo.png", maybe due to a newer version? >> For me it had to be src="_media/logo.png", maybe due to a newer version?
 >> DOK 2009-09-02 >> DOK 2009-09-02
 +>>> And on another install with an even newer version I had to go src="/dokuwiki/data/media/wiki/logo.jpg", which bypasses all php alltogether...
 +>>> DOK 2009-09-11
  
 > Thanks for documenting this. > Thanks for documenting this.
Line 37: Line 43:
 > to the layout.css will add the logo as a background to the header > to the layout.css will add the logo as a background to the header
 > Ferdinand Soethe, 2007-02-03 > Ferdinand Soethe, 2007-02-03
 +
 +----
 +For dokuwiki-2009-12-25c I had to do the following to get this to work.  Please note that my dokuwiki is in htdocs/mydoku :
 +
 +1. Created htdocs/mydoku/images and moved logo.jgp into it (I had read permission problems if I put the file in htdocs/mydoku/data/media)
 +
 +2. Specified the variable as:
 +
 +<code php>$conf['logo'      = '<img src="/mydoku/images/logo.jpg"/>';</code>
 +
 +It is tricky to debug because, until you get it all right, the image is either replaced with a ? or does not appear at all.  If you get a ?, try to Download Image or do some other manipulation on it.  That can give a clue to the problem.
 +
 +'Hope that this helps.
 +
 +hackerbie@gmail.com 29 April 2010
 +----
 +\\ 
 +In my case, using the following made ours work: 
 +
 +<code php>$conf['logo'       = '<img src="/dokuwiki/lib/exe/fetch.php?w=&h=&cache=cache&media=YourImage.png" alt="Highlight text when hovered over" />';</code>
 +
 +Took a while but we got there...Also, the dimensions had to be changed quite a bit, but that could have been due to the template we was using (mmClean)
 +
 +v.2010.07a-0
 +
 +**** We have also used the following: <code php>$conf['logo'       = '<img src="lib/tpl/mmclean/images/latin6.png</code>
 +
 +---- 
tips/image-in-the-upper-right-corner.1251883997.txt.gz · Last modified: 2009-09-02 11:33 by 164.140.159.143

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki