DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

This is an old revision of the document!


DokuWiki System Requirements

To run your own copy of DokuWiki you will need the following:

1. Webserver supporting PHP

DokuWiki will run on any web server, that supports PHP. Most users use Apache but many others including IIS, litespeed, lighttpd, nginx and Abyss are known to work.

2. PHP version 5.2 or later

PHP needs to be at least Version 5.2.

For resizing images either the PHP GD extension or Image Magick should be installed.

DokuWiki should work in PHP's Safe Mode, but depending on your hosting configuration you may need to use the safemodehack option.

The pcre library in PHP needs to be compiled with UTF-8 support. You can test this by executing pcretest -C and looking for “UTF-8 support” (or “UTF-8 and UTF-16 support”) and “Unicode properties support”. 1)

3. A recent browser

Any modern browser should work, but check our browser recommendations.

See also

1)
If UTF-8 support is missing, snippets in the search results will be missing and when you follow links in the search results the pages will be empty.
requirements.1414439169.txt.gz · Last modified: 2014-10-27 20:46 by 174.44.15.163

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki