DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
requirements [2023-02-04 13:01] – [PHP version 7.2 up to latest PHP version 7.4.x or PHP 8.0 - 8.1] 90.186.47.199requirements [2024-02-11 18:53] (current) andi
Line 1: Line 1:
 ====== DokuWiki System Requirements ====== ====== DokuWiki System Requirements ======
  
-To run your own copy of [[DokuWiki]] you will need the following:+To run your own copy of [[DokuWiki]] you will need a web server and PHP. You can either run this software yourself or use a [[install:hosted|hosting provider]].
  
-==== A Webserver supporting PHP ====+===== Web Server =====
  
-DokuWiki will run on any web server, that supports [[http://php.net/|PHP]]. Most users use [[http://httpd.apache.org/|Apache]] or [[https://nginx.org/en/|nginx]], but many others including [[https://www.iis.net|IIS]], [[https://www.litespeedtech.com/products/litespeed-web-server|litespeed]], [[https://www.lighttpd.net|lighttpd]], [[https://man.openbsd.org/httpd|OpenBSD httpd]] and [[https://aprelium.com/abyssws/|Abyss]] are known to work.+DokuWiki will run on any web server, that supports [[http://php.net/|PHP]].
  
-==== PHP version 7.2 up to latest PHP version 7.4.x or PHP 8.8.1====+Most users use [[http://httpd.apache.org/|Apache]] or [[https://nginx.org/en/|nginx]], but many others including [[https://www.iis.net|IIS]], [[https://www.litespeedtech.com/products/litespeed-web-server|litespeed]], [[https://www.lighttpd.net|lighttpd]], [[https://man.openbsd.org/httpd|OpenBSD httpd]], [[https://caddyserver.com/|Caddy]] and [[https://aprelium.com/abyssws/|Abyss]] are known to work.
  
-PHP needs to be at least version 7.2 since the « Igor » release, support for previous PHP versions has been dropped on this release. PHP versions up to and including 7.3 are now [[https://www.php.net/supported-versions.php|EOL]], therefore using the latest version of the 7.4.x branch or 8.x is highly recommended. Dokuwiki is compatible with PHP 8.0 and 8.1.+===== PHP ====
  
-For resizing [[:images]] either the [[phpfn>ref.image|PHP GD extension]] or [[http://www.imagemagick.org/|Image Magick]] should be installed+DokuWiki is written in the PHP scripting language and thus needs a compatible PHP interpreter. 
-==== A recent browser ====+ 
 +The current stable release requires PHP in version 7.4 or higher. 
 + 
 +PHP versions up to and including 7.4 have reached [[https://www.php.net/supported-versions.php|End of Life]]. Thus PHP 8 is recommended
 + 
 +Please refer to our page on [[install:php|recommended PHP settings]] for what extensions you should enable and recommended PHP configuration options.
  
-Any modern browser should work, but check our [[browser|browser recommendations]]. 
  
 ===== See also ===== ===== See also =====
Line 20: Line 24:
   * [[install|Installing DokuWiki]]   * [[install|Installing DokuWiki]]
   * [[install:php|Recommended PHP settings]]   * [[install:php|Recommended PHP settings]]
 +  * [[browser|Browser Recommendations]]
requirements.1675512064.txt.gz · Last modified: 2023-02-04 13:01 by 90.186.47.199

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki