DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
Next revisionBoth sides next revision
requirements [2021-04-29 11:46]
– [PHP version 5.6 up to latest PHP version 7.4.x] add a note about EOL versions of PHP mprins
requirements [2021-11-06 14:45]
– [A Webserver supporting PHP] added OpenBSD httpd openletter
Line 5: Line 5:
 ==== A Webserver supporting PHP ==== ==== A Webserver supporting PHP ====
  
-DokuWiki will run on any web server, that supports [[http://php.net/|PHP]]. Most users use [[http://httpd.apache.org/|Apache]] or [[https://nginx.org/en/|nginx]], but many others including [[https://www.iis.net|IIS]], [[https://www.litespeedtech.com/products/litespeed-web-server|litespeed]], [[https://www.lighttpd.net|lighttpd]] and [[https://aprelium.com/abyssws/|Abyss]] are known to work.+DokuWiki will run on any web server, that supports [[http://php.net/|PHP]]. Most users use [[http://httpd.apache.org/|Apache]] or [[https://nginx.org/en/|nginx]], but many others including [[https://www.iis.net|IIS]], [[https://www.litespeedtech.com/products/litespeed-web-server|litespeed]], [[https://www.lighttpd.net|lighttpd]], [[https://man.openbsd.org/httpd|OpenBSD httpd]], and [[https://aprelium.com/abyssws/|Abyss]] are known to work.
  
 ==== PHP version 5.6 up to latest PHP version 7.4.x ==== ==== PHP version 5.6 up to latest PHP version 7.4.x ====
Line 11: Line 11:
 PHP needs to be at least Version 5.6 but newer versions are highly recommended. Please note that Dokuwiki is not yet compatible with PHP 8. PHP needs to be at least Version 5.6 but newer versions are highly recommended. Please note that Dokuwiki is not yet compatible with PHP 8.
  
-Php 5.6 will not be supported in the next release and has some [[github>splitbrain/dokuwiki/issues/3474|quirk on Windows]], we recommend to use at least version 7.3 from now on, as PHP versions up to and including 7.2 are now [[https://www.php.net/supported-versions.php|EOL]].+Php 5.6 will not be supported in the next release and has some [[https://github.com/splitbrain/dokuwiki/issues/3474|quirk on Windows]], we recommend to use at least version 7.3 from now on, as PHP versions up to and including 7.2 are now [[https://www.php.net/supported-versions.php|EOL]].
  
 For resizing [[:images]] either the [[phpfn>ref.image|PHP GD extension]] or [[http://www.imagemagick.org/|Image Magick]] should be installed. For resizing [[:images]] either the [[phpfn>ref.image|PHP GD extension]] or [[http://www.imagemagick.org/|Image Magick]] should be installed.
requirements.txt · Last modified: 2022-05-05 08:54 by 49.167.224.38

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki