DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
Last revisionBoth sides next revision
requirements [2014-10-24 23:40] – [DokuWiki System Requirements] 79.31.171.91requirements [2022-08-02 04:39] – updated to reflect Igor release changes on php support Kuranes
Line 2: Line 2:
  
 To run your own copy of [[DokuWiki]] you will need the following: To run your own copy of [[DokuWiki]] you will need the following:
-Ciccio 
-Etc etc. 
-==== 1. Webserver supporting PHP==== 
  
-DokuWiki will run on any web server, that supports [[http://www.php.net|PHP]]. Most users use [[http://www.apache.org/httpd|Apache]] but many others including IIS, lighttpd, nginx and Abyss are known to work.+==== A Webserver supporting PHP ====
  
-==== 2. PHP version 5.or later ====+DokuWiki will run on any web server, that supports [[http://php.net/|PHP]]Most users use [[http://httpd.apache.org/|Apache]] or [[https://nginx.org/en/|nginx]], but many others including [[https://www.iis.net|IIS]], [[https://www.litespeedtech.com/products/litespeed-web-server|litespeed]], [[https://www.lighttpd.net|lighttpd]], [[https://man.openbsd.org/httpd|OpenBSD httpd]], and ,[[https://aprelium.com/abyssws/|Abyss]] are known to work.
  
-**PHP needs to be at least Version 5.2.**+==== PHP version 7.2 up to latest PHP version 7.4.x ====
  
-For resizing [[:images]] either the [[phpfn>ref.image|PHP GD extension]] or [[http://www.imagemagick.org|Image Magick]] should be installed.+PHP needs to be at least version 7.2 since the « Igor » release, Support for previous PHP versions has been dropped on this release. PHP versions up to and including 7.3 are now [[https://www.php.net/supported-versions.php|EOL]], therefore using the latest version of the 7.4.x branch is highly recommended. Please note that Dokuwiki is not yet compatible with PHP 8.
  
-DokuWiki should work in PHP'[[phpfn>features.safe-mode|Safe Mode]], but depending on your hosting configuration you may need to use the [[:config:safemodehack]] option.+For resizing [[:images]] either the [[phpfn>ref.image|PHP GD extension]] or [[http://www.imagemagick.org/|Image Magick]] should be installed.
  
-The pcre library in PHP needs to be compiled with UTF-8 support. You can test this by executing ''pcretest -C'' and looking for "UTF-8 support" (or "UTF-8 and UTF-16 support") and "Unicode properties support". ((If UTF-8 support is missing, snippets in the search results will be missing and when you follow links in the search results the pages will be empty.)) 
  
 ==== 3. A recent browser ==== ==== 3. A recent browser ====
requirements.txt · Last modified: 2022-08-02 09:01 by Klap-in

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki