DokuWiki

It's better when it's simple

User Tools

Site Tools


requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
requirements [2018-04-19 10:20]
lynne
requirements [2018-04-19 10:41] (current)
Klap-in old revision restored (2017-12-06 06:19) Please don't translate the english page
Line 1: Line 1:
-====== ​Dokuwiki 系统要求 ​====== +====== ​DokuWiki System Requirements ​======
-要运行您自己的 [[DokuWiki]],有以下几点建议:+
  
-==== 1. 支持PHP的网页服务器 ​====+To run your own copy of [[DokuWiki]] you will need the following:​ 
 + 
 +==== 1. Webserver supporting ​PHP====
  
 DokuWiki will run on any web server, that supports [[http://​php.net/​|PHP]]. Most users use [[http://​httpd.apache.org/​|Apache]] but many others including [[https://​www.iis.net|IIS]],​ [[https://​www.litespeedtech.com/​products/​litespeed-web-server|litespeed]],​ [[https://​www.lighttpd.net|lighttpd]],​ [[https://​nginx.org/​en/​|nginx]] and [[https://​aprelium.com/​abyssws/​|Abyss]] are known to work. DokuWiki will run on any web server, that supports [[http://​php.net/​|PHP]]. Most users use [[http://​httpd.apache.org/​|Apache]] but many others including [[https://​www.iis.net|IIS]],​ [[https://​www.litespeedtech.com/​products/​litespeed-web-server|litespeed]],​ [[https://​www.lighttpd.net|lighttpd]],​ [[https://​nginx.org/​en/​|nginx]] and [[https://​aprelium.com/​abyssws/​|Abyss]] are known to work.
-==== 2.PHP 5.6 及以上的运行环境 ​====+==== 2. PHP version ​5.6 or later ====
  
-最低支持PHP5.6 ,但强烈推荐使用新版本。+**PHP needs to be at least Version 5.6** but newer versions are highly recommended.
  
 For resizing [[:images]] either the [[phpfn>​ref.image|PHP GD extension]] or [[http://​www.imagemagick.org/​|Image Magick]] should be installed. For resizing [[:images]] either the [[phpfn>​ref.image|PHP GD extension]] or [[http://​www.imagemagick.org/​|Image Magick]] should be installed.
Line 17: Line 18:
 **PHP 7.0** installation (on Ubuntu 16.04 or debian 9) need the php-xml package installed. (Fixes error: Uncaught Error: Call to undefined function utf8_decode() ) **PHP 7.0** installation (on Ubuntu 16.04 or debian 9) need the php-xml package installed. (Fixes error: Uncaught Error: Call to undefined function utf8_decode() )
  
-==== 3. 浏览器推荐 ​====+==== 3. A recent browser ​====
  
-一般浏览器都可以使用如果不行,请查看 ​[[browser|有关浏览器的建议]].+Any modern browser should workbut check our [[browser|browser recommendations]].
  
-===== 也可以看看 ​=====+===== See also =====
  
-  * [[install|安装Dokuwiki]] +  * [[install|Installing DokuWiki]] 
-  * [[install:​php|推荐的PHP设置]]+  * [[install:​php|Recommended ​PHP settings]]
requirements.txt · Last modified: 2018-04-19 10:41 by Klap-in