DokuWiki

It's better when it's simple

User Tools

Site Tools


plugin:wysiwyg:discussion

Version 2

I have released a v2 beta if anyone's interested. It has a floating toolbar (except on IE6) and autosized work area. It also overrides the default “create page” behaviour for anyone in the 'wysiwyg' group.

I have left a link to the old version in case it breaks anyone's installation. You will probably need to clear your browser and server caches after installation.

Luke Howson 2007.11.30

Hi, I can't get the “wysiwyg” group thing to work. Can help? FIXME

Usability improvements

I am not able to find any icon to insert an external nor internal link using WYSIWYG plug in. I've tried to change the syntax.php file invoking the Default FCKeditor toolbar, without success. Is there any way to extend the functionality of WYSIWYG plugin. Thanks — Antonio Martínez 25-10-07

Maybe that's because the external and internal links have the very same syntax. They only differ in their “address syntax” (starting with “www.” or “http://”, etc.).

mediamanager integration

I've been trying to integrate mediamanager into WYSIWYG plugin, in the official FCKeditor documentation (FCKeditor) the solution is given changing the variable “ImageBrowserURL” and after image is selected make a call to seturl function.

I've made this but nothing happens, mediamanager isn't loaded and default imagebrowser is showed.

¿any idea?

Thanks— Manuel Munoz 2007.10.19

(implemented) DokuWiki 'create page' integration

While editing the <wysiywyg /> sections it pretty intuitive, the steps to create a new page with a WYSIWYG section is not (especially considering the target users of this plugin.) There are a few options I can think of, and am interested in others. I haven't looked into their technical difficulty:

  1. Adding a WYSIWYG option to skip the DokuWiki edit page step when creating a page based on a _template.txt in that namespace.
  2. Using a similar option in the pagetemplate plugin.
  3. A create page actionlink with a dialog asks whether you want 'simple or advanced' edit mode. (Less intrusive.)
  4. Overriding the DokuWiki editor for page creation altogether with a page that asks 'simple or advanced'. (More integrated.)
  5. Overriding the DokuWiki editor for page creation with automatic redirection depending upon the group membership of the user. (Although they might take offense at being a member of the 'simple' group.)

Personally, I quite like option 5.

Luke Howson 2007.10.12

Bugs

Help - Big trouble !

Often, the users click on the “Edit” tab - and not on the Edit link of the plugin. Aafter that, the page is lost!

The page is displayed in the standard DokuWiki edit mode with the content normally managed by the plugin:

<wysiwyg a-faire-valider-omsv >>>>>33008AD8-D1B7-4739-A27F-FB64353077D1<table class="wikitable" style="background-color: rgb(204, 255, 204);"><tbody><tr><th><strong>N&deg;</strong></th> 	<th><strong>Id</strong></th> 
etc...
<td>&nbsp;</td> 	<td>&nbsp;</td> 	<td>&nbsp;</td> 	<td>&nbsp;</td></tr></tbody></table>33008AD8-D1B7-4739-A27F-FB64353077D1<<<<< />

After that, the only way is to recreate the page from scratch !

Is it possible to restore the data?

Marc mas@smci.ch- 16.11.2007

You should be able to restore from an old revision. Click on the revisions button (or if you can't find it, attach ?do=revisions or &do=revisions to the end of the URL for that page.
Having said that, the HTML should not be visible within the DokuWiki editor. You should just see
<wysiwyg a-faire-valider-omsv />


If you can email me your DokuWiki installation I can have a look.
You can also use the ifauth plugin to hide the DokuWiki edit button from particular users or groups of users.
–Luke Howson mail@lukehowson.com 19.11.2007

script errors

When I include a wysiwyg tag in the source code. I get always a opened edit window on which I get edit and all but the “save” or “quit” buttons are not working with error:

 line: 74
 character: 1
 error: object expected

Looks like something is going wrong with the js-script. I'm using IE7 and the latest DokuWiki. I have userscript.js in conf/ defined.

I'm not sure what is going on here. Are you saying that the edit box is already opened when you load the page: that you don't have to click the edit button?
It may be that FCKeditor is not loading for some reason. I know this was a problem in earlier versions. Can you download and install the WYSIWYG plugin? Are there any other details with the error message. (e.g. a function name, filename, etc.) –Luke Howson
(Update) I have changed the way WYSIWYG operates. You may have more luck if you upgrade. Please let me know how you go. –Luke Howson 2007.10.31
Hello I'm someone else and I still have the problem, I downloaded the last version of your zip. What is weird is that on an another wiki I didn't have this problem… any Idea ?

ACTION_ACT_PREPROCESS conflict

I think it´s possible there´s a conflict with other plugins that use “ACTION_ACT_PREPROCESS” like blog, ¿is this possible?

What is the error exactly? I have both plugins installed. — Luke Howson 2007.10.11

(resolved) Warning on page creation

I get this warning: Invalid argument supplied for foreach() in C:\…\plugins\wysiwyg\hider.php on line14 I've been examining the code and I think the argument is the name associated with every wysiwyg tag. I don´t Know what´s the reason because the name is correct. Any idea?. Thanks

Make sure you have the latest version, and comment out the line listed in the installation notes. Let me know how you go. — Luke Howson 2007.10.11
Actually, just make sure you have the latest version. (I have done away with the kludge) — Luke Howson 2007.10.11
last version installed. I create a page and I put <wysiwyg name /> markup, when I save it I got the warning. However, the page is shown after this everything goes fine. I've trying to debug code and seems like if variable 'pickle' is empty in function save_wysiwyg first time the page is saved. Manuel Munoz 2007.10.11
Thanks Manuel. I have fixed this in the new version.
Thanks Luke. It works GREAT!!. Manuel Munoz 2007.10.11

(resolved) Recovering from the attic is broken

(I am raising and answering this bug. :) ) wysiwyg uses php sessions. You need to comment out the line “session_write_close();” in doku.php. I apologize for this kludge and am looking into it. — Luke Howson 4.10.07

using the latest version you don't need this kludge any more. — Luke Howson 2007.10.11

(resolved) Unresponsive edit button

I can´t get it working, when I install the plugin and use it in a wiki page I see the edit me link but nothing happens if I click it, any idea?

There should be a little grey button saying “edit” under the “edit me” text. It sounds like this isn't getting displayed. What browser are you using? So far I have only tested with IE7 and Firefox. (I intend to test it with IE6 next.) – Luke Howson
yes the little button appears but when clicked nothing happens, I tested it with Firefox & Internet Explorer with the same result. I've tried it with a clean installation too and I'm experiencing the same problem.
As I wrote privately to the author, the JavaScript code fails to load an object which should be created by the FCKeditor core. Perhaps the FCKeditor core is not correctly preloaded by the plugin. — Samuele Tognini 2007-10-01 17:42
There was a problem with code compaction. Please download v0.2 — Luke Howson 2007-10-02
I can´t find where´s v0.2, where can I find it?, thanks. —Manuel Muñoz 2007-10-02
Probably the old link points already to the new release, however the 0.2 does not fix the bug because the problem is that the path of JavaScript files does not contain the DokuWiki base path. This mean that it should work only if DokuWiki is installed in the root of your site. - Samuele
Thanks for tracking down the problem, Samuele. Fixed for v0.21. (Use the old link.) — Luke Howson
It works! — Samuele Tognini 2007-10-03 13:00

Thanks giving

I just wanted to express my gratitude, a really great job :) - sw

Thanks – Luke.

(integrated) Hiding Edit button

Any way to hide “Edit” WYSIWYG button for non-logged users? Thanks – Daniel.

Try to enclose the edit link in syntax.php into a conditional statement that checks user permissions, so where says:
$renderer->doc .= '<a onclick="wysiwyg_edit(\''.$name.'\');" class="wysiwyg_button button">edit</a><br />';


may say:

if ($aclLevel >=  AUTH_EDIT) { 
    $renderer->doc .= '<a onclick="wysiwyg_edit(\''.$name.'\');" class="wysiwyg_button button">edit</a><br />';
    }


Manuel Munoz 2007.10.28

The same functionality is in the new version. Luke Howson 2007.10.31

When I click the 'save' button after editing, nothing happen? even If I click the 'quit' button also nothing happen.

I am using latest version of DokuWiki with the monobook template. - Dean Dean

I'm having the same issue with the same template using DokuWiki Release 2008-05-05 - paulw 2008.09.02

Edit in table HTML

Hello, It is necessary to set fckconfig.js: FCKConfig.FormatIndentator =''; for the insertion of internal links, external links, footnotes, and so on in a table. Cordially. jmg - 14.11.2007 - mailto:jm [dot] griess [at] orange [dot] fr

Hello, this doesn't seem to help. When I insert a link using Wiki-Syntax, it is displayed as [[link]] but no link is actually created. Not only inside a table, also outside. Am I doing it the wrong way? How to insert links, both internal and external, inside a WYSIWYG section? Thanks. 2009-10-22

Full Wysiwyg

DokuWiki and FCKeditor is visible at arkheia (:!: link appears broken/for sale!) - Tests in playground available… Not a plugins, full integration and possible working [wiki] or [html] Cordially. jmg - 18.11.2007

This doesn't works

I use a modified version of addnewpage plugin, when I create the new page this way <wysiwyg [name] /> tag is inserted from a template. If I show the page everything works fine, edit link is seen and WYSIWYG content can be edited and saved. When I try to edit it again and I save again the content disappears, but when I edit the page with DokuWiki's edit button content is there, so the content is saved in the page but it´s not seen. I think may be possible a conflict with WYSIWYG 'wysiwyg_GUID' variable, any idea?

Manuel Munoz. 2007-11-18

More investigation about this bug

I´ve change my last opinion, now I think it´s because AJAX, when hider.php is working the user makes other action, so data are not corrected in the page and appears some text like in the bug reported by Marc mas@smci.ch- 16.11.2007. I think it would be useful a progress indicator on load/save through AJAX. I´ll continue investigating….

Manuel Munoz. 2007-11-18

Some problems using Cyrillic characters

Thanks for a great plugin. But I have some problems preventing me from regular using. When I create pages with Cyrillic characters (actually in Russian) it stores them like %u04222 and after reloading page seems to be broken. As far I can see DokuWiki uses utf8 internally to store wiki texts. So if I replace manually these character codes with corresponding letters it works, but until next edit/save cycle. Could someone explain what to do because I am a bit confused.

Michael V. Savchuk 2008-01-17

Go to /lib/plugins/wysiwyg/fckeditor/fckconfig.js and change:
FCKConfig.ProcessNumericEntities = false ;


to

FCKConfig.ProcessNumericEntities = true ;


Luke Howson 2008-01-29

Html To Wiki Syntax

Hello, Is it possible to convert the HTML code to DokuWiki syntax, which is produced by the FCKeditor? Unfortunately, if someone is using the integrated DokuWiki search a lot of HTML tags appear in the search results. I don't really care, but a lot of people a just afraid of “cryptic” signs, like they are afraid of the wiki-syntax. I'll be very happy for any advices or hints concerning HTML to wiki syntax. Thanks in advance.

I may do something to get rid of the search results gobbledygook, but not by converting into DokuWiki syntax. I have added an explanation to the main WYSIWYG page. At the moment, however, my priority is to add the upload / display of images and inserting internal links. - Luke Howson 2008-01-29

A possible solution with MediaWiki+FCKeditor project:

If someone can modify the FCKeditor for MediaWiki to work with DokuWiki.

All the html2wiki and wiki2html conversion are done via FCKeditor + JavaScript so no extra package to install. You can also quickly change between WYSIWYG and wikitext. They has made a lot of improvement that allow this to work correctly even on IE6. It is probably not that hard to modify this to use DokuWiki syntax instead of MediaWiki syntax ;)

Check out the SANDBOX page to see how this WYSIWYG extension significantly improve the usability of the wiki for both new and experienced users.

Edit, Save and Quit Buttons won't work

Hello,

I have a DokuWiki on a Stick installation and the problem is that the WYSIWYG buttons won't work. I can edit all, but I can't save or quit.

Any idea?

Thanks Robert P. 15.09.08

Edit, Save and Quit Buttons won't work (me too)

Edit, save, and quit don't work for me either using IE6 and FF3 and latest DokuWiki version.

Any chance of a fix?

Thanks, jason@whaleshark.org

I can confirm WYSIWYG is not working in FF3 and latest DokuWiki version. As described here, nothing happens when clicking on the edit button
Bit I have no problems with IE6, even when having “Maximum section edit level” set to >0.
scsi 2009-01-16

Edit, Save and Quit Buttons won't work (I am using DokuWiki on a stick)

Edit, save, and quit don't work for me. I am using DokuWiki on a stick version which is installing on portable USB drive. Is there a fix for it or am I doing something wrong?

Thanks.

WYSIWYG and ACL

Hello,

Your plugin works well when I am logged as a full access user. I'm trying to use it with several namespaces. I have created users who have write access to their namespace and read access to the whole wiki. They can edit the page to add the wysiwyg tag but when they click on edit, they have an alert “You don't have permission to edit this page.”

I don't understand which rights are missing. It's not possible to use namespace to limit access?

Thx.


It seems that there is a mistake in plugins/wysiwyg/ajax.php
The line (129) $ID = getID(); should be executed before auth_aclcheck()
As far as I know, it works.
Harold. 04.02.09

Undefined ID

Hi, I installed the WYSIWYG plugin on a DokuWiki installation. I'm getting an error with both IE 6 and Firefox 3. The Edit Me clearly appears, but the edit button doesn't. Also, IE gives me that error:

Line: 2

Car: 39292

Error: 'ID' is not defined.

Code: 0

URL: http://localhost/dokuwiki/lib/plugins/wysiwyg/fckeditor/editor/fckeditor.html?InstanceName=page&Toolbar=dokuwiki

I just added some icons in the toolbar, but I don't really think this is related. If someone can help me about that, he's welcome. Thanks in advance!

fixed, the plugin was just not compatible with syntaxhighlighter, and since it doesn't really work for me now, disabling it solved the problem. But it might be helpful to have a look on this compatibility problem for those who are using it.

Monobook

using the latest version of monobook, the plugin works fine, I modified the style.css of wysiwyg

div#wysiwyg_adobe_style_toolbar
{
	position:fixed;
	top: 2.8em;
	z-index:20000;
	width:100%;
	left: 13.2em;
}

It's a bit rough though, but it works =)

The greatest annoyance are the drop down menu's, those things drop at a absolute location, in stead of relative. Does anyone know how to fix that??

– Theo

WYSIWYG Bug report

my version is WYSIWYG 1.6.1,when the cursor of mouse on the edit button,there is a JavaScript error on 73 row,and the error is object is not exist;

the browser is IE6.0

Very good so far

I just installed and debugged your latest stable version (wysiwyg2). The debugging was necessary because of numerous missing files during the FTP upload (i.e., the notoriously commonplace FTP process corruption). In other words, it was not because of any deficiency in the software.

The Wiki experience of most of the users I'm dealing with is limited to WetPaint, whose “Easy Edit” editor is WYSIWYG-only. Now I'm able to give them an ad-free Wiki and an editor that looks familiar to them—one that is more versatile than the one they've been abusing (er, using).

I have three comments (formerly two, but I found something else):

  1. There appears to be no way to specify the use of lowercase letters or Roman numerals for an ordered list. Is this a planned enhancement?
  2. Your Background Color button is actually a highlighting button, as it only colors the background of selected text. You should change the mouseover caption to Highlight, which is consistent with MS Word practice.
  3. It's very easy to create a centered table. However, after saving, it moves left. Going back into edit mode restores it to the center (as long as one stays in edit mode). I only tried the default 3-row, 2-column format. I'll try others and will also try pasting one from MS Word.

Additional comment (regarding a problem), added 2010-05-19

The special WYSIWIG save (under the Edit window) appears to work, in that there is no error message and both the WYSIWYG edit link and the DocuWiki Edit button reappear (but there is no explicit success message). However, when I return to the page after going elsewhere, it's empty. Attempting to restore from the current entry at the top of the revision list makes no difference, other than to include the edit link (and only the edit link). Attempting to restore from any previous revision (pre-WYSIWYG installation revision, owing to the non-saving of WTSIWYG revisions) gives raw XHTML code. (I know how to deal with that, but, given that it is indeed pre-WYSIWYG, there's not much point in doing it.)

Bill Potts, Roseville, CA

plugin/wysiwyg/discussion.txt · Last modified: 2014-03-13 16:53 by 196.203.59.237