DokuWiki

It's better when it's simple

User Tools

Site Tools


plugin:poll

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
Last revision
plugin:poll [2010-09-20 16:03]
213.61.78.248 added link to new Doodle2 plugin
plugin:poll [2019-10-14 23:58]
cgalo Removed [Languages], work shouldn't be done in plugin page
Line 2: Line 2:
  
 ---- plugin ---- ---- plugin ----
-description: Lets you add polls to a wiki page. (previous authors: Esther Brunner) +description: Lets you add polls to a wiki page 
-author     : Gina Häußge, Michael Klier +author     : Dokufreaks (previous author: Gina Häußge, Michael Klier, Esther Brunner) 
-email      : dokuwiki@chimeric.de+email      : freaks@dokuwiki.org
 type       : syntax type       : syntax
-lastupdate : 2008-02-14+lastupdate : 2016-04-25
 compatible : >=2006-11-06 compatible : >=2006-11-06
 depends    :  depends    : 
Line 12: Line 12:
 similar    : userpoll similar    : userpoll
 tags       : poll, !experimental tags       : poll, !experimental
 +downloadurl: https://github.com/dokufreaks/plugin-poll/archive/master.zip
 +sourcerepo : https://github.com/dokufreaks/plugin-poll/tree/master
 +bugtracker : https://github.com/dokufreaks/plugin-poll/issues
 ---- ----
- 
-^ Download | [[http://www.chimeric.de/_src/plugin-poll.tgz|plugin-poll.tgz]] | 
  
 ===== Syntax ===== ===== Syntax =====
  
-Use this [[plugins|plugin]] to add a poll to a wiki page. The syntax looks like this:+Use this plugin to add a poll to a wiki page. The syntax looks like this:
  
   <poll [id]>   <poll [id]>
Line 37: Line 38:
  
 ===== Demo ===== ===== Demo =====
-You can see the demo here : http://www.ichiayi.com/wiki/tech/dokuwiki_plugin/poll+ 
 +You can see the demo here: http://www.ichiayi.com/wiki/tech/dokuwiki_plugin/poll FIXME
  
  --- //[[tryweb@ichiayi.com|Jonathan Tsai]] 2008/08/29 21:01//  --- //[[tryweb@ichiayi.com|Jonathan Tsai]] 2008/08/29 21:01//
  
 ===== Installation Notes ===== ===== Installation Notes =====
 +
 When the [[blog]] plugin is also installed, you need to turn ''$conf['plugin']['blog']['useifmodifiedsince']'' off. I will try to eliminate this incompatibility. When the [[blog]] plugin is also installed, you need to turn ''$conf['plugin']['blog']['useifmodifiedsince']'' off. I will try to eliminate this incompatibility.
-===== Languages ===== 
  
-The "Vote" Button needs to be translated to other languages. Currently only German (de) and English (en) are available. [[wikidesign@gmail.com|Send me]] your translation! 
->I've just send the Russian one, but without exclamation sign at the end... Feel free to add it, that sign in Russian means just the same. 
-//Gleb// 
  
->In French you can write "Voter" or "Voter !", as Gleb just said before me :) +===== Bugs Feature Requests =====
-//Maxime//+
  
-> In Norwegian "Stem" +Please report bugs or feature requests at the [[https://github.com/dokufreaks/plugin-poll/issues|Bug tracker]].
-//Andreas Åkre Solberg//+
  
->In Dutch "Stem" or "Stem !"+===== Changes =====
  
->In Czech "Hlasuj" or "Hlasuj!" :-) +{{rss>https://github.com/dokufreaks/plugin-poll/commits/master.atom date}}
-//Tonda//+
  
->In Polish "Zagłosuj"+===== Discussion =====
  
->In Swedish "Rösta" 
-//Coredev// 
  
->In Brazilian Portuguese "Votar" +---- 
-//Marlon//+**How to allow multiple polls in one page** 
  
->In Spanish from México (LatinAmerica"Votar" +In the file ... /lib/plugins/pool/synthax.php\\ 
-//Eleazar//+Add the parameter $title to the function _pollForm 
 +<code> 
 +<    function _pollForm($options, &$renderer{ 
 +>    function _pollForm($options, &$renderer, $title) {   
 +</code> 
 +Add it in it's call too: 
 +<code> 
 +<                $renderer->doc .= $this->_pollForm($options, $renderer); 
 +>                $renderer->doc .= $this->_pollForm($options, $renderer, $title); 
 +</code>
  
->In Latvian "Balsot+add md5($title) to group radio name in the form 
-//Aivars//+<code> 
 +<                '<input type="radioname="vote" id="poll__option'.$i.'" '. 
 +>                '<input type="radio" name="vote'.md5($title).'" id="poll__option'.$i.'" '. 
 +</code> 
 +and finally add md5($title) to the radio button filter  
 +<code> 
 +<            } elseif ($vote = $_REQUEST['vote']) { 
 +>            } elseif ($vote = $_REQUEST['vote'.md5($title)]) { 
 +</code>
  
->In Turkish "Oy ver" +Note that the votes should be submitted one by one
-//ismail//+
  
->In Italiano "Vota" +Have a nice day, 
-//Xamuel//+----
  
->>In Chinese "投票". 
-//Dean Peng// 
- 
->>In Korean "투표". The 1st non-Latin char! 
-//cppig1995// 
- 
->>In Esperanto "Voĉdoni". Attention: "Voĉdonu" is not correct as this implies that you give your computer orders as you would do when talking to other persons. 
-//Denizo// 
- 
->>In Danish "Stem" 
-//Denizo// 
- 
->In Hungarian "Szavazz" 
- 
->In Romanian "Votează" 
- 
->In Lithuanian "Balsuoti" 
-//TAHU// 
- 
->In Bulgarian "Гласувай!" 
-//tok7886// 
- 
->In Ukrainian "Голосую" 
-//Zalex_UA// 
- 
->In Russian "Голосую" 
-//Zalex_UA// 
-===== Bugs / Feature Requests ===== 
-Please report bugs or feature requests at the [[http://github.com/dokufreaks/plugin-poll/issues|Bug tracker]]. 
- 
-===== Further Resources ===== 
-  * [[http://github.com/dokufreaks/plugin-poll/tree/master|Git Repository]] 
-  * [[http://github.com/dokufreaks/plugin-poll/issues|Bug Tracker]] 
- 
-===== Changes ===== 
- 
-{{rss>http://github.com/feeds/dokufreaks/commits/plugin-poll/master}} 
- 
-===== Discussion ===== 
  
 I am running DokuWiki 3.09. I am getting the following error  I am running DokuWiki 3.09. I am getting the following error 
plugin/poll.txt · Last modified: 2019-10-15 05:41 by tryweb