DokuWiki

It's better when it's simple

User Tools

Site Tools


plugin:pgpinlinesupport

PGP-Inline-Support Plugin (pgpinlinesupport)

Compatible with DokuWiki

  • 2018-04-22 "Greebo" yes
  • 2017-02-19 "Frusterick Manners" unknown
  • 2016-06-26 "Elenor Of Tsort" unknown
  • 2015-08-10 "Detritus" unknown

plugin This plugin enables support of using inline pgp encryption.

Last updated on
2019-01-07
Provides
Syntax
Repository
Source
Conflicts with
unknown

Tagged with mailvelope, pgp

Installation

Install the plugin over the webfrontend by using the url:

https://github.com/user9209/PGP-Inline-Support-DokuWiki/archive/master.zip

How to use

Use Mailvelope (https://www.mailvelope.com):

  1. Generate a Key-Pair
  2. Add current tab to “Authorized Domain” (do NOT use API)
  3. When editing a page press Mailvelope-Button and encrypt text
  4. Save page as normal
  5. See Mailvelope-Button on page
  6. Press decrypt and enter your password

Without this Plugin, step will 6 fail.

Why should you use it? What does it fix?

Video:

Change Log

  • 2019-01-07
    • Initial release

Known Bugs and Issues

  • not yet known
plugin/pgpinlinesupport.txt · Last modified: 2019-01-08 03:22 by user4546