DokuWiki

It's better when it's simple

User Tools

Site Tools


plugin:openlayersmapoverlays

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
plugin:openlayersmapoverlays [2014-04-16 18:12]
218.82.183.53 [Change Log]
plugin:openlayersmapoverlays [2019-03-21 18:03] (current)
mprins new version
Line 6: Line 6:
 email      : mprins@users.sf.net email      : mprins@users.sf.net
 type       : syntax type       : syntax
-lastupdate : 2014-04-10 +lastupdate : 2019-03-21 
-compatible : Angua, Adora Belle, Weatherwax, Binky+compatible : Angua, Adora Belle, Weatherwax, Binky, Ponder Stibbons, Hrun, Detritus, 2016-06-26, 2017-02-19, Greebo
 depends ​   : openlayersmap depends ​   : openlayersmap
 conflicts ​ :  conflicts ​ : 
Line 13: Line 13:
 tags       : media maps embed geo spatial tags       : media maps embed geo spatial
  
-downloadurl:​ http://​sourceforge.net/​projects/​dokuwikispatial/files/​openlayersmapoverlays/​openlayersmapoverlays.zip/download +downloadurl:​ http://netcologne.dl.sourceforge.net/​project/​dokuwikispatial/​openlayersmapoverlays/​openlayersmapoverlays.zip 
-sourcerepo : https://​sourceforge.net/​p/​dokuwikispatial/​code/​+sourcerepo : https://​sourceforge.net/​p/​dokuwikispatial/​code/​HEAD/​tree/​trunk/​openlayersmapoverlays/
 bugtracker : https://​sourceforge.net/​p/​dokuwikispatial/​issues/​ bugtracker : https://​sourceforge.net/​p/​dokuwikispatial/​issues/​
 ---- ----
 +
 ===== Installation ===== ===== Installation =====
  
-:!: **External requirements:​** This plugin requires the following additional components that must be installed separately: [[openlayersmap]] (If you run the -snapshot release of one you must run the -snapshot version of the other)+:!: **External requirements:​**\\  
 +This plugin requires the following additional components that must be installed separately: [[openlayersmap]] (If you run the -snapshot release of one you must run the -snapshot version of the other)
  
-Install ​the plugin using the [[plugin:plugin|Plugin ​Manager]] ​and the download ​URL above, which points to latest version of the plugin. Refer to [[:​Plugins]] on how to install plugins manually.+Search and install ​the plugin using the [[plugin:extension|Extension ​Manager]] ​or manually with the download ​from the [[http://​sourceforge.net/​projects/​dokuwikispatial/​files/​openlayersmapoverlays/​openlayersmapoverlays.zip/​download|SourceForge Mirror]]. Refer to [[:​Plugins]] on how to install plugins manually. ​
  
 ===== Examples/​Usage ===== ===== Examples/​Usage =====
Line 40: Line 42:
  
 Where ''​id''​ is the id of the openlayersmap,​ ''​name''​ is the name of this map layer, ''​url''​ is the WMS layer url, ''​layers''​ are the layers from the map service that you want displayed, ''​visible''​ defines whether the layer is visible when the layer is added to the map, ''​attribution''​ is displayed in the attribution area of the map frame. Where ''​id''​ is the id of the openlayersmap,​ ''​name''​ is the name of this map layer, ''​url''​ is the WMS layer url, ''​layers''​ are the layers from the map service that you want displayed, ''​visible''​ defines whether the layer is visible when the layer is added to the map, ''​attribution''​ is displayed in the attribution area of the map frame.
 +
 +====Mapillary====
 +To add a Mapillary layer to your map use the following syntax:
 +
 +  <​olmap_mapillarylayer id="​olMap"​ visible="​true"></​olmap_mapillarylayer>​
 +
 +Where ''​id''​ is the id of the openlayersmap and ''​visible''​ defines whether the layer is visible when the layer is added to the map
 +
 +To add a specific sequence to the map use the following syntax:
 +
 +  <​olmap_mapillarylayer id="​olMap"​ visible="​true"​ skey="​4t2k4Oaq1MezwMbMVNIgHA"></​olmap_mapillarylayer>​
 +
 +''​skey''​ being the sequence identifier.
 +
 +:!: Please note the [[http://​www.mapillary.com/​developer.html|Mapillary conditions]] for using this layer on your website:
 +  * Non-commercial use and small scale use for early demos and prototypes are free of charge
 +  * Commercial use of the API and Mapillary data requires an agreement with Mapillary
 +  * Attribution is required (this is built-in).
 +
 ===== Development ===== ===== Development =====
  
 ==== Change Log ==== ==== Change Log ====
 +=== version 4.14 ===
 +  * made in conjunction with the [[openlayersmap]] plugin version 4.14
  
-===1.3===+=== version 4.13 === 
 +  * made in conjunction with the [[openlayersmap]] plugin version 4.13 
 + 
 +=== version 4.12 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.11 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.10 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.9 === 
 +  * some PHP 7 fixes 
 + 
 +=== version 4.8 === 
 +  * - 
 + 
 +=== version 4.7 === 
 +  * PHP 7 compatibility fixes 
 + 
 +=== version 4.6 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.5 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.4 === 
 +  * use latest version of OpenLayers 2.14-dev 
 + 
 +=== version 4.3 ===
   * use OpenLayers 2.14-dev   * use OpenLayers 2.14-dev
-===1.2.1===+ 
 +=== version 4.2 === 
 +  * use OpenLayers 2.14-dev 
 +  * sync version number with openlayersmap;​ as of this version the version numbers should be the same. 
 +  * add support for Mapillary 
 + 
 +===version 1.4=== 
 +  * use OpenLayers 2.14-dev 
 + 
 +===version ​1.2.1===
   * use OpenLayers 2.13.1   * use OpenLayers 2.13.1
-===1.2===+ 
 +===version ​1.2===
   * use OpenLayers 2.13   * use OpenLayers 2.13
  
-===1.1=== +===version ​1.1=== 
-  * provides WMS support1+  * provides WMS support
  
-===1.0===+===version ​1.0===
   * initial release, provides XYZ support   * initial release, provides XYZ support
- 
plugin/openlayersmapoverlays.1397664737.txt.gz · Last modified: 2014-04-16 18:12 by 218.82.183.53