DokuWiki

It's better when it's simple

User Tools

Site Tools


plugin:logautherror

logautherror Plugin

Compatible with DokuWiki

2011-05-25 "Rincewind", Angua

plugin It log in apache error_log when an authentification fail. Is usefull with fail2ban !

Last updated on
2011-12-16
Provides
Action
Repository
Source

This extension has not been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues.

Tagged with logging, security

By Astrel

Installation

Install the plugin using the Plugin Manager and the download URL above, which points to latest version of the plugin. Refer to Plugins on how to install plugins manually.

Nothing else ! Just If you install this plugin manually, make sure it is installed in lib/plugins/logautherror/ - if the folder is called different it will not work!

If you want use it with fail2ban (was developped for it) make sure you have the filter 'apache-auth.conf'

Configuration and Settings

WARNING : Do not change the log message error if you did not know how you made. The default log message error match with 'apache-auth.conf' config. fail2ban version 0.8.4

Development

Change Log

Known Bugs and Issues

No bug with fail2ban version fail2ban-0.8.4 – Tested on CentOS 5 and 6

ToDo/Wish List

Nothing Else ! More idea contact me ! or make an issue if you found bug !

Discussion

  • on Debian Wheezy: Had to change the very end of the failregex from \s*$ to .*$ in /etc/fail2ban/filter.d/apache-auth.conf

Open

plugin/logautherror.txt · Last modified: 2014-10-19 21:28 by 134.76.62.65