DokuWiki

It's better when it's simple

Narzędzia użytkownika

Narzędzia witryny


pl:requirements

Różnice

Różnice między wybraną wersją a wersją aktualną.

Odnośnik do tego porównania

pl:requirements [2008-04-21 00:01]
127.0.0.1 edycja zewnętrzna
pl:requirements [2012-01-07 23:50] (aktualna)
78.8.114.32
Linia 1: Linia 1:
 +
 +
 +
 ====== Wymagania systemowe DokuWiki ====== ====== Wymagania systemowe DokuWiki ======
-Do uruchomienia swojej kopii [[DokuWiki]] będą potrzebne następujące trzy elementy: 
  
-  - Serwer www z obsługą [[phpfn>|PHP]] +Do uruchomienia kopii [[DokuWiki]] będą potrzebne następujące trzy elementy: 
-    * Preferowany jest serwer [[http://www.apache.org/httpd|Apache]]ale na wielu innych również działa poprawnie + 
-  - [[http://www.php.net/|PHP]] w wersji 4.3.3 lub wyższej. Ze względu na  [[http://secunia.com/advisories/13481/|sprawy bezpieczeństwa]] szczególnie polecany jest PHP w wersji 4.3.10 lub wyższej. ((RedHat Enterprise Linux [[https://rhn.redhat.com/errata/RHSA-2006-0276.html|przeportował]] te poprawki bezpieczeństwa do wcześniejszych wersji: php-4.3.2-30 dla RHEL V3, php-4.3.9-3.12 dla RHEL V4)) (PHP 5 powinien być w porządku.) +==== 1. Serwer www z obsługą PHP ==== 
-    * Włączenie [[http://de.php.net/manual/en/ini.core.php#ini.short-open-tag|krótkich tagów]] nie powinno być potrzebne ((jeśli napotkasz problem, wyślij [[bugs|zgłoszenie o błędzie]])) + 
-    * [[http://de2.php.net/manual/en/ref.image.php|Rozszerzenie GD]] dla PHP((do użycia z biblioteką graficzną [[http://www.boutell.com/gd/|libGD 2]])) jest zalecane, jednak nie wymagane +DokuWiki będzie działać na dowolnym serwerze obsługującym [[http://www.php.net|PHP]]. Większość użytkowników korzysta z [[http://www.apache.org/httpd|Apache]] ale wiadomo, że działa też na wielu innych, w tym IIS, lighttpd, Nginx, i Abyss. Korzystanie z wiki w jako aplikacji desktopowej można również obsłużyć przez [[http://www.zachsaw.com/?pg=quickphp_php_tester_debugger QuickPHP]] (serwer www i PHP jednym pliku). 
-    DokuWiki powinien pracować włączoną obsługą [[phpfn>features.safe-mode|Safe Mode]] PHP, jednak zależności od konfiguracji twojego hostingu może wymagać ycia opcji [[safemodehack]] +  
-    * DokuWiki został zaprojektowany do używania z wyłączoną opcją [[phpfn>register_globals]] w PHP+   
-    Jeżeli zamierzasz wysyłać maile potwierdzające rejestrację dla nowych użytkowników, PHP powinien zostać skonfigurowany do poprawnego ich wysyłania. (zobacz: [[phpfn>mail]]) +   
-  - Przyzwoita przeglądarka internetowa (zobacz [[compatibility|listę kompatybilnych przeglądarek]])+==== 2. PHP w wersji 5.1.lub późniejszej ==== 
 + 
 +PHP musi być w wersji co najmniej 5.1.2. 
 + 
 +Do skalowania [[:images|grafik]] powinno być zainstalowane [[phpfn>ref.image|rozszerzenie PHP GD]] albo [[http://www.imagemagick.org|Image Magick]]
 + 
 +DokuWiki powinna działać w [[phpfn>features.safe-mode|Trybie bezpiecznym]] PHP, jednak zależnie od konfiguracji hostingu być może trzeba yć opcji [[:config:safemodehack]]. 
 + 
 + 
 +==== 3. Nowa przeglądarka ==== 
 + 
 +Powinna działać dowolna nowoczesna przeglądarka, jednak sprawdź [[browser|zalecenia odnośnie przeglądarki]]. 
 + 
 + 
 +===== Patrz również ===== 
 + 
 +  * [[install|Instalacja DokuWiki]] 
 +  * [[install:php|Zalecane ustawienia PHP]] 
 +  * [[compatibility|Lista kompatybilności przeglądarek]]
  
-[[plugins|Wtyczki]] lub opcje jak [[spell checker|sprawdzanie pisowni]] może wymagać dodatkowych zasobów. 
pl/requirements.txt · ostatnio zmienione: 2012-01-07 23:50 przez 78.8.114.32