DokuWiki

It's better when it's simple

Narzędzia użytkownika

Narzędzia witryny


Pasek boczny

This translation is older than the original page and might be outdated. See what has changed.
Translations of this page?:

Learn about DokuWiki

Advanced Use

Corporate Use

Our Community


Follow us on Facebook, Twitter and other social networks.

Our Privacy Policy

pl:requirements

To jest stara wersja strony!


Wymagania systemowe DokuWiki

Do uruchomienia swojej kopii DokuWiki będą potrzebne następujące trzy elementy:

  1. Serwer www z obsługą PHP
    • Preferowany jest serwer Apache, ale na wielu innych również działa poprawnie
  2. PHP w wersji 4.3.3 lub wyższej. Ze względu na sprawy bezpieczeństwa szczególnie polecany jest PHP w wersji 4.3.10 lub wyższej. 1) (PHP 5 powinien być w porządku.)
    • Włączenie krótkich tagów nie powinno być potrzebne 2)
    • Rozszerzenie GD dla PHP3) jest zalecane, jednak nie wymagane
    • DokuWiki powinien pracować z włączoną obsługą Safe Mode w PHP, jednak w zależności od konfiguracji twojego hostingu może wymagać użycia opcji safemodehack
    • DokuWiki został zaprojektowany do używania z wyłączoną opcją register_globals w PHP.
    • Jeżeli zamierzasz wysyłać maile potwierdzające rejestrację dla nowych użytkowników, PHP powinien zostać skonfigurowany do poprawnego ich wysyłania. (zobacz: mail)
  3. Przyzwoita przeglądarka internetowa (zobacz listę kompatybilnych przeglądarek)

Wtyczki lub opcje jak sprawdzanie pisowni może wymagać dodatkowych zasobów.

1)
RedHat Enterprise Linux przeportował te poprawki bezpieczeństwa do wcześniejszych wersji: php-4.3.2-30 dla RHEL V3, php-4.3.9-3.12 dla RHEL V4
2)
jeśli napotkasz problem, wyślij zgłoszenie o błędzie
3)
do użycia z biblioteką graficzną libGD 2
pl/requirements.1208728917.txt.gz · ostatnio zmienione: 2012-01-07 23:50 (edycja zewnętrzna)