DokuWiki

It's better when it's simple

ユーザ用ツール

サイト用ツール


サイドバー

この翻訳は元のページよりも更新日が古く、内容が古い可能性があります。 変更点を参照して下さい。
このページの翻訳?:

DokuWiki について知る

開発

法人利用

我々のコミュニティ


FacebookTwitterや他のソーシャル・ネットワークからフォローしてください。

ja:faq:pluginproblems

新しくインストールしたプラグインが動作しない

:?: 新しいプラグインをインストールしましたが、全く動作しません。

:!: ほとんどのプラグインをインストールするための一番良い方法は、プラグイン管理を使用することです。この方法は、一番問題が発生しにくい方法です。もしプラグインを手動で (すなわち Wiki のプラグインフォルダに展開して) インストールした場合、もしくは古いバージョンの DokuWiki を使用している場合は、以下の説明が役に立つかもしれません。

キャッシュ

  • conf/local.php ファイルを touch (ファイルの更新日時を変更) することにより、DokuWiki のキャッシュが削除されていることを確認してください。
  • ブラウザのキャッシュを使用せず、関係するページを強制的にリロード (Shift-F5、Ctrl-F5、Ctrl-Shift-R などで) するようにしてください。
  • 最後の手段として、サーバ上の <dokuwiki>/data/cache/ 以下のファイルを削除したいと思うかもしれません。過去にこの方法で解決した事例があります。

依存関係

  • すべてのプラグインが PHP4 互換というわけではありません。念のため、PHP5 を使用してください。
  • いくつかのプラグインは依存関係を持っています (他のプラグインがインストールされている必要があったり、外部アプリケーションが必要であったりします)。必要となるすべてのモジュールがインストールされているかどうか、プラグインのページの説明文を確認してください。
  • すべてのプラグインがすべての DokuWiki のバージョンで動作するわけではありません。互換性情報が言及されていないかどうか、プラグインのページを確認してください。
ja/faq/pluginproblems.txt · 最終更新: 2010-01-11 16:41 by kazmiya