DokuWiki

It's better when it's simple

ユーザ用ツール

サイト用ツール


サイドバー

この翻訳は元のページよりも更新日が古く、内容が古い可能性があります。 変更点を参照して下さい。
このページの翻訳?:

DokuWiki について知る

開発

法人利用

我々のコミュニティ


FacebookTwitterや他のソーシャル・ネットワークからフォローしてください。

ja:plugin:upgrade

アップグレードプラグイン

互換性のある DokuWiki バージョン

adora belle, weatherwax, binky, Ponder Stibbons

plugin 管理画面から数回クリックしてDokuWikiをアップグレードする

最終更新日
2014-06-22
種類
Admin
リポジトリ
ソース

この拡張は二年以上更新されていません。もはや維持管理や対応がされておらず、互換性に問題がある可能性があります。

This extension is not in the 'plugin' or 'template' namespace and is therefore ignored.

類似 elwikiupgrade

タグ update

ダウンロードとインストール

上記の URL からプラグイン管理を使用してプラグインのダウンロードとインストールをして下さい。 手動でインストールする方法については プラグイン を参照して下さい。

変更履歴

使用方法

このプラグインは、管理インターフェイスに「Wiki のアップグレード」という新しいオプションを追加します。 ウィザードの指示に従い、数ステップで、自分のwikiを最新の安定版 DokuWikiにアップグレードしてください。

注意:このプラグインには data フォルダー内のファイルだけではなく、DokuWikiの全ファイルへの書込権限が必要です。 DokuWiki ダウンローダーで DokuWiki をインストールしたのであれば、権限は問題ないはずです。 心配は要りません。 このプラグインは実際にアップグレード処理を実行する前に、必要な権限を確認します。

このプラグインは “Lemming” 以降からのアップグレードしかテストしていません。 より古いバージョンからのアップグレードも同じように動くと思います。

:!: アップグレード前の wiki のバックアップを作成すること(DokuWiki のバックアップ方法参照)を強くお薦めします。 このプラグインはバックアップを作成しません。 :!:

:!: このプラグインを実行する前に、プラグインの新バージョンが利用可能になっていないかを確認し、プラグインのアップグレードを最初に実施してください。:!:

Q&A

インターネット接続外の環境でも使用できますか?

プラグインは新しいリリースを github.com リポジトリから直接ダウンロードします。 そのため、インターネットに直接アクセスする必要があります。

PHP の必要条件は?

php_opensslを有効にしてコンパイルされていることを確認して下さい。

Webroot 外にフォルダーを移動してあります。問題になりますか?

現在、アップグレードプラグインは conf ディレクトリをデフォルトの場所から移動した場合に対応していません。

data ディレクトリを移動している場合、プラグインは data ディレクトリをデフォルトの場所に再作成します。 このディレクトリは後で安全に削除できます。 アップグレード後、あなたの data ディレクトリに新規サブフォルダーを手動作成する必要があるかもしれません。

Weatherwax へのアップグレード

Weatherwax へのアップグレードにこのプラグインを使用することは、プレーンテキスト認証機能を使用している場合にしかお勧めできません。 他の認証バックエンドの場合、手動での設定調整が必要になるようです。

ja/plugin/upgrade.txt · 最終更新: 2014-06-25 19:10 by 220.107.196.43