DokuWiki

It's better when it's simple

User Tools

Site Tools


install:gentoo

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
install:gentoo [2017-06-27 02:38]
50.4.233.35 [Install]
install:gentoo [2017-06-27 02:57]
50.4.233.35
Line 17: Line 17:
   APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D SSL -D SSL_DEFAULT_VHOST -D LANGUAGE -D PHP"   APACHE2_OPTS="-D DEFAULT_VHOST -D INFO -D SSL -D SSL_DEFAULT_VHOST -D LANGUAGE -D PHP"
  
-We assume that you'll use the ''webapp-config'' process to control wikipedia'space on your server:+We assume that you'll use the ''webapp-config'' process to control dokuwiki space on your server:
   $> equery l webapp-config   $> equery l webapp-config
   * Searching for webapp-config ...   * Searching for webapp-config ...
Line 28: Line 28:
  
 To use this example, ''vhosts'' will need to be recognized by your dokuwiki package.  In a new file: To use this example, ''vhosts'' will need to be recognized by your dokuwiki package.  In a new file:
-  /etc/portage/package.use/wikipedia+  /etc/portage/package.use/dokuwiki
 ...be sure there's something like: ...be sure there's something like:
   www-apps/dokuwiki vhosts   www-apps/dokuwiki vhosts
Line 48: Line 48:
               virtual-hosting environment               virtual-hosting environment
  
-If you don't like what you see there -- for instance, if the ''vhosts'' setting shows up "-" instead of "+" and you want to keep following the instructions here -- build the ''dokuwiki'' package again.+If you don't like what you see there -- for instance, if the ''vhosts'' setting shows up "-" instead of "+" and you want to keep following the instructions here -- find and fix any changes necessary, and build the ''dokuwiki'' package again.
  
 To use the ''webapp-config'' command, be sure you know the version you're using; equery can tell us that too.  As of 26 June 2017, we find version ''20170219b'': To use the ''webapp-config'' command, be sure you know the version you're using; equery can tell us that too.  As of 26 June 2017, we find version ''20170219b'':
install/gentoo.txt ยท Last modified: 2017-06-27 02:57 by 50.4.233.35