DokuWiki

It's better when it's simple

User Tools

Site Tools


config:gdlib

This is an old revision of the document!


Configuration Setting: gdlib

For resizing images DokuWiki uses PHP's libGD if available. DokuWiki tries to detect the availability and version of libGD automatically. However, in older PHP versions, this does not work. You can force a version by setting this variable. Possible values are: ‘0’ for no libGD support; ‘1’ for libGD version 1.x; and ‘2’ for libGD 2 with autodetect.

Resizing function that accepted this setting is deprecated since Igor Release, July 2022. Setting is not used in the newer cropping/resizing functionality.

  • Type: Number
  • Default: 2

See also

config/gdlib.1659296988.txt.gz · Last modified: 2022-07-31 21:49 by Klap-in

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International
CC Attribution-Share Alike 4.0 International Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki