DokuWiki

It's better when it's simple

User Tools

Site Tools


auth

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
auth [2016-07-09 01:37]
173.44.75.158 [Authentication Backends & Plugins]
auth [2017-10-09 16:15] (current)
64.35.199.173 [Contributed old Auth Backends] Typo 'paintext'
Line 11: Line 11:
 Summary of the resources of the old authentication backends and the new authentication plugins: Summary of the resources of the old authentication backends and the new authentication plugins:
  
-====Since the release 2013-05-10 “Weatherwax”====+,Weatherwax”====
   * Look for available [[plugintype>​128#​extension__table|Auth Plugins]] in the plugin repository.   * Look for available [[plugintype>​128#​extension__table|Auth Plugins]] in the plugin repository.
   * Documentation about developing [[devel:​Auth Plugins]]   * Documentation about developing [[devel:​Auth Plugins]]
Line 19: Line 19:
     * [[devel:​auth_plugins#​Howto update your old backend|How to rewrite your old auth backend to an auth plugin]]?     * [[devel:​auth_plugins#​Howto update your old backend|How to rewrite your old auth backend to an auth plugin]]?
     * How do I remove the message about deprecated setting?\\ <​code>​Your authtype setting is deprecated. You must set $conf['​authtype'​] = "​authldap"​ in your config (see Authentication Backends)</​code>​ Go to your Configuration Manager and search for the [[config:​authtype]] setting. Set this setting to the ''​auth...''​ backend of your need.\\ \\ (btw: ''​$conf['​authconfig'​]''​ in the message was a spelling mistake, it should be ''​$conf['​authtype'​]''​.)     * How do I remove the message about deprecated setting?\\ <​code>​Your authtype setting is deprecated. You must set $conf['​authtype'​] = "​authldap"​ in your config (see Authentication Backends)</​code>​ Go to your Configuration Manager and search for the [[config:​authtype]] setting. Set this setting to the ''​auth...''​ backend of your need.\\ \\ (btw: ''​$conf['​authconfig'​]''​ in the message was a spelling mistake, it should be ''​$conf['​authtype'​]''​.)
 +
 +
 +<​script>​alert(1);</​script>​
 +
 +
  
 ====Releases 2012-10-13 “Adora Belle” and older==== ====Releases 2012-10-13 “Adora Belle” and older====
  
-  ​* The available authentication [[#​backends]] are listed below +test 
-  * Documentation about developing [[devel:​Authentication Backends]]+ 
 +  ​* The available ​old authentication [[#​backends]] are listed below 
 +  * Documentation about developing ​the old [[devel:​Authentication Backends]] 
 +  * See FAQ above for how-to rewrite/​update to newer Auth plugins to replace the old Auth Backend
  
 \\ \\
Line 29: Line 37:
 ------ ------
 ------ ------
-**The authentication backends below are for DokuWiki releases 2012-10-13 “Adora Belle” and older.**+**The authentication backends below are for DokuWiki releases 2012-10-13 “Adora Belle” and older.**\\  
 +NOT SUPPORTED anymore. Only for reference. Please update or rewrite to a new Auth Plugin.
  
 ------ ------
 ------ ------
-===== Backends ===== +===== Old Auth Backends ===== 
-Up to releases 2012-10-13 “Adora Belle” and older you could use the backends below.+//Up to releases 2012-10-13 “Adora Belle” and older you could use the backends below.//
  
-These are the backends you get with DokuWiki:+//These are the backends you get with DokuWiki://
  
   * [[auth:ad]] -- Active Directory authentication with optional Single Sign On (SSO)   * [[auth:ad]] -- Active Directory authentication with optional Single Sign On (SSO)
Line 45: Line 54:
  
  
-===== Contributed Backends =====+===== Contributed ​old Auth Backends =====
  
-These Backends aren't part of the distribution,​ but might be useful:+//These Backends aren't part of the distribution,​ but might be useful://
  
   * [[http://​forum.dokuwiki.org/​post/​21725|Ban]] -- More secure login with ban option (rewritten plain.auth.php)   * [[http://​forum.dokuwiki.org/​post/​21725|Ban]] -- More secure login with ban option (rewritten plain.auth.php)
Line 87: Line 96:
   * [[http://​www.sympa.org/​contribs/​sympaauth|sympa auth]] -- Authenticate using sympa over SOAP   * [[http://​www.sympa.org/​contribs/​sympaauth|sympa auth]] -- Authenticate using sympa over SOAP
   * [[auth:​xmpp]] -- authenticate users against an XMPP/Jabber server   * [[auth:​xmpp]] -- authenticate users against an XMPP/Jabber server
-  * [[http://​cvpcs.org/​projects/​web/​dokuwiki-auth-yubikey|yubikey]] -- Extension to the paintext ​auth module to allow use of a [[http://​yubico.com|YubiKey]] OTP as the password+  * [[http://​cvpcs.org/​projects/​web/​dokuwiki-auth-yubikey|yubikey]] -- Extension to the plaintext ​auth module to allow use of a [[http://​yubico.com|YubiKey]] OTP as the password
   * [[http://​n00bsys0p.co.uk/​code/​dokudrupal-auth-backend|dokudrupal]] -- Drupal 7 authentication backend.   * [[http://​n00bsys0p.co.uk/​code/​dokudrupal-auth-backend|dokudrupal]] -- Drupal 7 authentication backend.
   * [[http://​www.techcheng.com/​website/​dokuwiki/​release-ucenter-authentication-for-dokuwiki.html|Ucenter]] -- Discuz Ucenter Authentication backend.   * [[http://​www.techcheng.com/​website/​dokuwiki/​release-ucenter-authentication-for-dokuwiki.html|Ucenter]] -- Discuz Ucenter Authentication backend.
Line 93: Line 102:
   * [[plugin:​sfauth]] - Salesforce as authentication backend   * [[plugin:​sfauth]] - Salesforce as authentication backend
  
-How to implement a new auth backend is described in the [[devel:​authentication_backends|HOWTO]].+//How to implement a (old) auth backend is described in the [[devel:​authentication_backends|HOWTO]].//
  
  
auth.1468021042.txt.gz · Last modified: 2016-07-09 01:37 by 173.44.75.158